cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LiveSite Doesn't Work, Support Can't Be Reached

Very frustrated, as always, with GoDaddy's complete lack of customer support. LiveSite can't install and gives an error of "! The selected version 2019.1 is not compatible with the selected install location. Requirements: php 5.3-7.1.99 (detected: 7.2.6)." Nor is this an issue with LiveSite itself, because I can install it fine on A2 Hosting through their CPanel. So I'm assuming GoDaddy or Installatron didn't set up the PHP installation correctly.

 

Apparently GoDaddy has no email contacts for tech support. Attempting to call them says my phone number is matched on the account with a certain PIN that I never even set up (I wouldn't set up a four digit PIN for GoDaddy anyway, I reserve those for financial institutions, and I'm not going to put the one I use in for a group I didn't even set one up for). So their phone support system doesn't work either. Attempting to call the British line says my account has a balance due and monthly date that aren't even mine, and once again I can't get through to a live person.

 

I have used numerous hosting sites since 2004 when I started web designing, and GoDaddy has easily the worst tech support of any site I've encountered. Fortunately I host with A2 Hosting and will continue to do so, because I need working tech support and this is ridiculous.

1 REPLY 1

Also, after posting this, another GoDaddy survey came up asking how I would rate GoDaddy and, after giving it a rating of 0, I get an error message saying the survey couldn't be submitted (the second time it's happened). I'm guessing the surveyer refuses to submit negative responses, which only further lowers my opinion of GoDaddy.