• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Highlighted

    Invalid connection string attribute

    Trying to connect Windows ODBC 8.0 drivers to a remote GoDaddy "managed WordPress hosting" MySQL database (ver 5.7.26-29). I believe I have all the MySQL ODBC parameters setup correctly but returns “Invalid connection string attribute”.

    I CAN connect to the database using MySQL Workbench with the same parameters, so it seems I have the server, user, password, port correct.

    Any ideas?

    1 ACCEPTED SOLUTION

    Accepted Solutions
    Highlighted
    Super User III
    Super User III
    Solution

    Re: Invalid connection string attribute

    @jbrown08322 

     

    Someone else just posted in the forum this morning - to the best of my knowledge you cannot update the MySQL password - support "maybe" able to - but I don't know if they would update the wp-config file if they did that

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post

    6 REPLIES 6
    Highlighted
    Super User III
    Super User III

    Re: Invalid connection string attribute

    @jbrown08322 

     

    What is your connection string??

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Highlighted

    Re: Invalid connection string attribute

    Here are some screen shots of the ODBC DSN failure and the Workbench that does work. 

    What would be different setting the ODBC?

     

    ScreenShot_ODBC_fails.jpgScreenShot_WB_OK.jpg

    Highlighted
    Super User III
    Super User III

    Re: Invalid connection string attribute

    @jbrown08322 

     

    Only thing I can think of is in that screen shot you don't have the database selected

     

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Highlighted

    Re: Invalid connection string attribute

    Found this link, and it happens the password does have a } in it. Sure enough if I type something different for the password I get "bad password" rather than the "Invalid....".

    I'll have to have the web site owner reset the password before I can try again, but I suspect I'll be OK.

     

    https://community.qlik.com/t5/QlikView-Deployment/ODBC-Connect-button-in-QV-script-returns-quot-Inva... 

    Highlighted

    Re: Invalid connection string attribute

    Web site owner was on phone with several GoDaddy support folks. But they must be first level support and did not really know what to do. They walked him thru adding a new WordPress user, but that does not help.
    When I get to the Starfield phpMyAdmin login, there is a forgot password that mentions “Hosting Control Center”. Where would the “Starfield” center be?

    Starfield logon.jpg

    Highlighted
    Super User III
    Super User III
    Solution

    Re: Invalid connection string attribute

    @jbrown08322 

     

    Someone else just posted in the forum this morning - to the best of my knowledge you cannot update the MySQL password - support "maybe" able to - but I don't know if they would update the wp-config file if they did that

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post