Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't add DKIM TXT record

Getting an error when attempting to add a DKIM record.

Message says to contact support - of which there is no obvious mechanism to do so.

I've checked and rechecked the method, selector and key - there is no mistake. Have changed TTL but that hasn't helped.

Where the f%$k is a support link for this service to report system issues??


Hey @dkimpain,

Adding a DKIM record is not something that we support, which is why you are unable to locate a help article. You will want to research a solution by using your favorite search engine. Hopefully, one of our other community members will chime in.

KayJay - GoDaddy | Community Moderator
24/7 support available at

i having the same problem. Problem appears to be the save button.

That is big help from godaddy.

Go Daddy!

What??!? That's horrible service. The least you could do is write some simple instructions. Might take 3 minutes from someone who knows about DNS. Oh, probably no one there at Go Daddy. Very sad.

A DKIM dns record it's always a TXT record. So you just need to create the correct host name (selector._domainkey) and add the desired content to the record. That's all.

I am trying to sell a few domain Names in my GoDaddy domain list on the Flippa site.  I need to add a TXT Record.  I can get to the A record but dont know what to do now.  

Hi @onlineauction,

Here's our help article on how to add a TXT record: Hope this helps! Take care!


RachelM - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.

Turns out that GoDaddy does not like _ (underscore) character in the host field for some unfathomable reason (other DNS do).

It also automatically appends the domain name to your entry.

So if AWS asks you to enter, say

you need to change that to


Problem solved. 

You can then verify with

 nslookup -type=TXT

or whatever is your NS server.


Same logic applies to all TXT entries, not just DKIM.


Hello to all, I am new to this comunity and I dont like to write much but I felt obligated due to the lack of Godady's support and common sence from them. Yes... I know, they suck and this can be proved a thousand times. Nice smiles, happy replies but the truth is most of the time disapointing. By now you can feel I am not a Goddady's fan but I am forced to have some products so I have to go ahead...


Solution to create DKIM is very simple though they will not tell you, not even give you a hint but here it is how I solved it:


1- First of all, DKIM has to be a TXT record

2- The common HOST that work on 99% of the rest of the planet like "default._domainkey.yourdomain." does no work in Goddady at all

3- You have to guess (and this is the worst part) that your domain part has to be deleted and your record should look like this "default._domainkey."

4- Doing so, will work


Please note that "default" is the selector you created when setting up DKIM in your email server so in my case was "deafult", you have to make sure which one you have and replace it.


For the record, it took me about a week to guess, test and curse goddady many times etc until I finnaly solved it. 


Hope it helps and if you can, please go away from Goddady. Perhaps this post will never be published because of my poor sympathy to them 🙂



Hi @juancaco,


Welcome to the Community!

Thank you for your input. For the information of our users here, we wish to clarify that a DKIM record may not be used - will not function - in shared hosting. It is only appropriate for use on our VPS and dedicated servers. 



TLH - GoDaddy | Community Moderator
Supporting you at