cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
yth2
New

Difficulty installing an SSL Certificate - help articles aren't helping

I just have called support because suddenly and an SSL certificate purchased via GoDaddy did not work with a DNS purchased, renewed and hosted via GoDaddy.
The reply? Let me sent you the documentation.
I told them that I already spent 3 hours trying to apply the recommended action stated in the documentation without success, and that is why I needed help.
The reply? Sorry, the only thing I can do is send you the documentation!
What a shameful, terrible, useless support (especially in this difficult situation where it is not easy for anyone!)
It is needless to say that I am done with GoDaddy, and I will not recommend it to anyone!

Yves

7 REPLIES 7
PL281
Super User II

@yth2 

First off I am an end user. I'm not quite following what you are saying regarding SSL certificate and "DNS Purchased" - I can only assume you mean domain registration.

 

Can you provide your domain and what specifically is the issue.

 

I can tell you that while GoDaddy does help with many basic settings on domains and some other areas - things like managing SSL certificates - unless it is part of something that is included with one of their platforms generally is outside the scope of support - the main reason for this with SSL specifically, is that there are many different configurations / operating systems which SSL certificates can be installed on and they are all slightly different - also if not installed correctly they can take down an entire server.

 

I believe this is why GoDaddy refers you to documentation as to how to install the certificate as guidance 

 

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Hi @PL281 I'm having a similar problem. I have 2 domains hosted with GD and I got a ssl Cert from GD. as well, it says it all installed ok but when I edited the .htaccess with the code they recommended, it broke the main site and won't redirect to the https side and still says not safe in chrome. 

 

How can I fix this? any tips?

 

Tim. 

PL281
Super User II

@Tim34 

 

I'm not sure if this is the same issue that @yth2  is having, but let's for the moment assume it is.

Can you walk me through what steps you've done and post any screen captures of those steps.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

@PL281 

 

ok so I got the SSL Cert from GD as in fig1

Fig 1.png

Then I went about adding the code suggested in this help document: https://my.godaddy.com/help/redirect-my-cpanel-website-to-https-27870

into the .htaccess file.

And thats when my website broke, displaying every element in a single row without any of the formatting.

Screen Shot 2020-05-07 at 8.37.47 PM.png

 

And up the top it's still displaying the "not secure" near the address.

 

You are right, I don't think it's the same problem but everything I've tried hasn't worked (I've put everything back to the way it was before I started in the .htaccess file)

PL281
Super User II

@Tim34 

 

Thanks for the screen postings this is very helpful - So it looks like you've added the SSL certificate onto the server, but it still needs to be "activated" on the domain - In cPanel if you go to SSL status you should see green locks - I'm guessing you aren't / won't - so I would go back to the screen where you see the SSL certificate and click the install link on the far right - on the 2nd screen you should be able to select the domain and say fill from certificate and the click install

 

Then before updating the .htaccess file just try going to https://oxytimin.com - the only thing the .htaccess file does is to redirect the traffic

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

PL281
Super User II

@Tim34 

 

I just took another look at https://oxytimin.com/ and the issue here is that you have references in your code to http:// and that is causing the issue 

If you edit <base href="http://www.oxytimin.com/" /> in your code and change it to https:// it should solve the issue

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

@PL281 

Problem Solved

 

I had installed the cert already and I was seeing the green locks:

Screen Shot 2020-05-07 at 10.26.41 PM.png

 

But I tried editing the config.php file and changed it to https and that appears to have done the trick.

 

Thank you for your help, it is much appreciated.

 

Tim.