cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Re: connecting to a mysql db thru php

I seem to be having the same problem but I have given the users all privileges and I get the following error:

 

Failed to connect to MySQL: Access denied for user 'Heidi'@'localhost' to database 'TDHSimages'

2 REPLIES 2
Super User III
Super User III

Re: connecting to a mysql db thru php

@mikeb11 

 

I have created a new posting for you rather than linking onto an old post that has already been resolved.

 

As per the old post - I suggest that you delete the user and recreate it.

 

One thing of note, it is case sensitive - for the user / password and database



I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Re: connecting to a mysql db thru php

When I first came across this error, I thought I was stupidly making a mistake with the connection command but I have run out of ideas what that stupidity might be.  There is an alternative scenario that I am now considering.  First, some background:

 

I already successfully run this application (and a couple of other MySQL applications) on an older hosting platform on GoDaddy.  I am porting the application to a platform that uses cPanel for a friend (this is all volunteer work in support of local history research).

 

For a number of years GoDaddy has been suggesting I port my site to cPanel.  I could not see any advantage in doing so and did nothing.  Then earlier this year GoDaddy told me that they were going to move the site to cPanel.  A little later the MySQL applications stopped working.  GoDaddy support said this was a Chrome browser problem and that Chrome in incognito mode and other browsers would work, which seemed to be correct.  The next day the problems disappeared and I presumed, not knowing anything about cPanel, that the port was successful.  I now realize that the port was abandoned and that the site is still running on the old platform.

 

There must be GoDaddy engineers that understand what is going on but I have no way of communicating with them.

 

I am going to withdraw this issue until I can better characterize it.

 

My recent checks include: making sure the names and the character cases are correct, testing with a couple of browsers - the problem does not seem to be browser dependent.